cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nick Bailey (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CASSANDRA-1856) nodetool "snapshot" improvements
Date Tue, 14 Dec 2010 05:43:02 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-1856?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12971169#action_12971169
] 

Nick Bailey commented on CASSANDRA-1856:
----------------------------------------

see CASSANDRA-1791

The patch there fixes the naming issue. It will name the snapshot directory only using the
passed in value and will default to a timestamp if nothing is supplied.  The mbean has also
been updated to take a list of keyspaces, with no keyspaces provided meaning 'all'.  It isn't
currently possible to specify by CF so maybe that should still be addressed.

> nodetool "snapshot" improvements
> --------------------------------
>
>                 Key: CASSANDRA-1856
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-1856
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Tools
>            Reporter: Robert Coli
>            Assignee: Jon Hermes
>            Priority: Trivial
>
> Summary : "nodetool snapshot" is actually hooked up to the MBean endpoint takeAllSnapshot.
takeAllSnapshot snapshots all CFs in all Keyspaces. 
> It would be good if "nodetool snapshot" took a mandatory Keyspace argument and an optional
(list of?) CF name(s?), perhaps mapped to "takeSnapshot" instead of "takeAllSnapshot".
> =Rob
> PS - 
> As a side note, I have never been too pleased with the behavior of "nodetool snapshot"
as regards snapshot naming. Most of the time, when someone names something something specific,
it ends up actually named that something, but.. 
> "nodetool snapshot foobarbaz" 
> ... does not result in a snapshot at "/path/to/datadir/Keyspace/snapshots/foobarbaz",
the snapshot ends up at "/p/t/dd/Keyspace/snapshots/<TIMESTAMPLOOKINGTHING>-foobarbaz".
> When I asked jbellis about this, he basically said it was to avoid having to deal with
the possibility that the directory might already exist. If you are mucking about in the snapshot
code, you might (or might not!) want to "fix" this behavior. :D

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message