cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Dusbabek (JIRA)" <j...@apache.org>
Subject [jira] Updated: (CASSANDRA-1670) cannot move a node
Date Mon, 01 Nov 2010 16:01:37 GMT

     [ https://issues.apache.org/jira/browse/CASSANDRA-1670?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gary Dusbabek updated CASSANDRA-1670:
-------------------------------------

    Fix Version/s: 0.7.0

> cannot move a node
> ------------------
>
>                 Key: CASSANDRA-1670
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-1670
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 0.6.6
>         Environment: RAX
>            Reporter: Matthew F. Dennis
>            Assignee: Gary Dusbabek
>             Fix For: 0.6.7, 0.7.0
>
>         Attachments: 1670-0.6.txt
>
>
> two node cluster (node0, node1).  node0 is listed as the only seed on both nodes.  Listen
addresses explicitly set to an IP on both nodes. No initial token, no autobootstrap (but see
below).  Bring up the ring.  Everything is fine on both nodes.
> decom node1.  verify decom completed correctly by reading the logs on both nodes.  rm
all data/logs on node1.  bring node1 up again.
> One of two things happen:
> * node0 thinks it is in a ring by itself, node1 thinks both nodes are in the ring.
> * both node0 and node1 think they are in rings by themselves
> If you restart node0 after decom, it appears to work normally.
> Similar issues seem to present if you kill node1 (either when autobootstrapping before
it completes or after it is in the ring) and removetoken.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message