cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Onnen (JIRA)" <>
Subject [jira] Commented: (CASSANDRA-1377) NPE aborts streaming operations for keyspaces with hyphens ('-') in their names
Date Tue, 24 Aug 2010 03:06:17 GMT


Erik Onnen commented on CASSANDRA-1377:

Thanks Jonathan. I added one additional patch to relax things slightly in 0.7 trunk. Tested
with a nodetool loadbalance and nodetool move with a two node ring and both worked fine. Lots
of changes in the streaming code between 0.6 and 0.7 and it looks like the broken code didn't
move forward into 0.7 near as I can tell in reading though it.

> NPE aborts streaming operations for keyspaces with hyphens ('-') in their names
> -------------------------------------------------------------------------------
>                 Key: CASSANDRA-1377
>                 URL:
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 0.6.3
>            Reporter: Ben Hoyt
>            Assignee: Gary Dusbabek
>             Fix For: 0.6.5, 0.7 beta 2
>         Attachments: 1377-0.6.txt, CAS-1377-1.patch, CAS-1377.patch, v1-0001-disallow-invalid-ks-cf-names.txt
> When streaming starts for operations such as repair or bootstrap, it will fail due to
an NPE if they rows are in a keyspace that has a hyphen in its name.  One workaround for this
issue would be to not use keyspace names containing hyphens.  It would be even nicer if streaming
worked for keyspace names with hyphens, since keyspaces named like that seem to be fine in
all other ways.
> To reproduce:
>  1. With a multi-node ring, load up a keyspace with a hyphen in its name
>  2. Add some data to that keyspace
>  3. nodetool repair
> Expected results:
> Repair operations complete normally
> Actual results:
> Repair operations don't complete normally.  The stacktrace below is correlated with the
repair request.  
>  INFO [AE-SERVICE-STAGE:1] 2010-06-30 14:11:29,744 (line 619)
Performing streaming repair of 1 ranges to / for (my-keyspace,AColumnFamily)
> ERROR [MESSAGE-DESERIALIZER-POOL:1] 2010-06-30 14:11:30,034
(line 101) Error in ThreadPoolExecutor
> java.lang.NullPointerException
>         at org.apache.cassandra.streaming.StreamInitiateVerbHandler.getNewNames(
>         at org.apache.cassandra.streaming.StreamInitiateVerbHandler.doVerb(
>         at
>         at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(
>         at java.util.concurrent.ThreadPoolExecutor$
>         at

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message