cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erick Tryzelaar (JIRA)" <j...@apache.org>
Subject [jira] Updated: (CASSANDRA-994) re-organize endpointsnitch implementations
Date Sat, 17 Apr 2010 09:07:25 GMT

     [ https://issues.apache.org/jira/browse/CASSANDRA-994?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Erick Tryzelaar updated CASSANDRA-994:
--------------------------------------

    Attachment: 0001-Rename-internal-uses-of-EndPoint-to-Endpoint.patch
                0002-Rename-internal-uses-of-endPoint-to-endpoint.patch
                0003-Rename-files-named-EndPoint-to-Endpoint.patch

The first 3 of 4 patches that implements this. These in particular change the spelling of
an end point to endpoint or Endpoint, not endPoint or EndPoint.

> re-organize endpointsnitch implementations
> ------------------------------------------
>
>                 Key: CASSANDRA-994
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-994
>             Project: Cassandra
>          Issue Type: Task
>    Affects Versions: 0.7
>            Reporter: Jonathan Ellis
>            Assignee: Erick Tryzelaar
>             Fix For: 0.7
>
>         Attachments: 0001-Rename-internal-uses-of-EndPoint-to-Endpoint.patch, 0002-Rename-internal-uses-of-endPoint-to-endpoint.patch,
0003-Rename-files-named-EndPoint-to-Endpoint.patch
>
>
> I think the EPS implementations should look like this:
> IEndPointSnitch: rename to IEndpointSnitch (lowercase P), otherwise fine as it is
> SimpleSnitch: new default snitch.  Implement IEPS directly, with sorting as no-ops.
> AbstractEndpointSnitch: rename to AbstractRackAwareSnitch; replace isOnSameRack and isInSameDataCenter
with getRack and getDatacenter (replacing getLocation).
> EndPointSnitch: rename to RackInferringSnitch
> PropertyFileEndpointSnitch: rename to PropertyFileSnitch, move from contrib to src
> DatacenterEndpointSnitch: remove (redundant wrt PFS). "quorum factor per DC" needs to
go in the ReplicationStrategy, not the snitch.
> The patch sequence looks like:
> 01: perform renames of IEPS, AES, EPS, and PFES
> 02: add SS and make method changes to ARAS [was AES]
> Separate ticket: DatacenterReplicationStrategy code changes

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message