cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Coli (JIRA)" <>
Subject [jira] Updated: (CASSANDRA-871) Two small cosmetic patches for inconsistent names in the JMX interface
Date Wed, 10 Mar 2010 07:57:27 GMT


Robert Coli updated CASSANDRA-871:

    Attachment: getRangeToEndPointMap.To.getRangeToEndpointMap.patch

> Two small cosmetic patches for inconsistent names in the JMX interface
> ----------------------------------------------------------------------
>                 Key: CASSANDRA-871
>                 URL:
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Core
>            Reporter: Robert Coli
>            Priority: Minor
>         Attachments: getRangeToEndPointMap.To.getRangeToEndpointMap.patch,
> Two small (cosmetic) changes (against 921220) to the names of things exposed via JMX
> 1) converts the name of the GOSSIP_STAGE JMXEnabledThreadPoolExecutor
to "GOSSIP_STAGE" instead of the cryptic/legacy name "GMFD" in src/java/org/apache/cassandra/concurrent/
> 2) getRangeToEndPointMap.To.getRangeToEndpointMap.patch changes all occurances of getRangeToEndPointMap
to be "getRangeToEndpointMap" instead, in 5 different files. Practical result is that StorageService's
MBean Operations no longer has both getRangeToEndPointMap (capital P Points) and getNaturalEndpoints
(lower case p points).
> As a note, both "EndPoint" and "Endpoint" are used throughout the code currently. If
folks feel there is any value to picking one ("Endpoint" per jbellis) and cosmetically patching
to that standard, I am wlillng to do the work to generate the patches.. :)
> =Rob
> .

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message