cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Evans (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CASSANDRA-547) authentication and authorization functions (stage 1)
Date Thu, 14 Jan 2010 20:45:54 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-547?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12800351#action_12800351
] 

Eric Evans commented on CASSANDRA-547:
--------------------------------------

First off, sorry for the delay, I meant to get back to this sooner and got tied up.

I think we're at the point were we could commit, just a few remaining nits:

* Let's do away with DatabaseDescriptor.setAuthenticator, configuration like this should effectively
be read-only.
* Can you include a default entry w/ comments in conf/storage-conf.xml for setting the Authenticator?
* I think we should also include commented samples for passwd.properties and authorization.properties
in conf/
* I'd also like to see the username parsing in authorization.properties a bit more forgiving,
at the very least splitting on one or more whitespace characters would be too easy not to
do.

There are also a few styling nits I would change myself prior to committing, but while you
are in there...

* can you rename CassandraServer.login_done to CassandraServer.loginDone to fit with convention.
* (null == foo()) strikes me as odd every-time I see it, (foo() == null) is more idiomatic,
at least for the Cassandra code base.

And one last thing.

It would make review simpler if you could group logical changes by patch and, when it makes
sense, to attach follow-up patches that are meant to be applied on top of the previous one
(while obviously leaving the previous patch attached to the issue).

In fact, if you could incorporate this latest round of feedback as a new patch that applied
on top of the existing one, so that I can more easily see those specific changes, I promise
to expedite it.

Thanks Ted.


> authentication and authorization functions (stage 1)
> ----------------------------------------------------
>
>                 Key: CASSANDRA-547
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-547
>             Project: Cassandra
>          Issue Type: New Feature
>          Components: Core
>            Reporter: Ted Zlatanov
>            Assignee: Ted Zlatanov
>         Attachments: CASSANDRA-547-auth.patch
>
>
> Add functions to login() and setKeyspace().  Check against authentication+authorization
backends whether those calls should succeed or fail.
> Create file-based and LDAP backends to implement authentication and authorization.
> Create AllowAll backend to allow all access.
> Add configuration stanza to specify the auth backend.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message