cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sandeep Tata (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CASSANDRA-393) rename storageendpoint overloads for clarity
Date Wed, 26 Aug 2009 21:37:59 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-393?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12748166#action_12748166
] 

Sandeep Tata commented on CASSANDRA-393:
----------------------------------------

+1, makes good sense.
The maps actually get Hinted and that should be reflected in the name.

> rename storageendpoint overloads for clarity
> --------------------------------------------
>
>                 Key: CASSANDRA-393
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-393
>             Project: Cassandra
>          Issue Type: Task
>            Reporter: Jonathan Ellis
>            Priority: Minor
>
> StorageService:
> getNLiveStorageEndPoint(String):List<EndPoint>
> getNStorageEndPoint(String):EndPoint[]
> getNStorageEndPoint(Token):EndPoint[]
> getNStorageEndPoint(Token, Map<Token, EndPoint>):EndPoint[]
> getNStorageEndPointMap(String):Map<EndPoint, EndPoint>
> getNStorageEndPoints(String[]):Map<String, EndPoint[]>
> some of these should be getWriteSEP. Some getHintedSEP. Some getReadSEP.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message