cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sandeep Tata (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CASSANDRA-393) rename storageendpoint overloads for clarity
Date Sat, 29 Aug 2009 00:38:32 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-393?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12749044#action_12749044
] 

Sandeep Tata commented on CASSANDRA-393:
----------------------------------------

+1

There's an unused HashMap import in RackUnaware and RackAware Strategies we could get rid
of.
Otherwise, it looks good, unit tests pass, nosetests pass.

> rename storageendpoint overloads for clarity
> --------------------------------------------
>
>                 Key: CASSANDRA-393
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-393
>             Project: Cassandra
>          Issue Type: Task
>          Components: Core
>            Reporter: Jonathan Ellis
>            Assignee: Jonathan Ellis
>            Priority: Minor
>             Fix For: 0.4
>
>         Attachments: 0001-CASSANDRA-393-r-m-unnecessary-IReplicationStrategy-int.txt,
0002-r-m-LoadVerbHandler-and-unused-endpoint-related-code.txt, 0003-rename-remaining-methods.txt
>
>
> StorageService:
> getNLiveStorageEndPoint(String):List<EndPoint>
> getNStorageEndPoint(String):EndPoint[]
> getNStorageEndPoint(Token):EndPoint[]
> getNStorageEndPoint(Token, Map<Token, EndPoint>):EndPoint[]
> getNStorageEndPointMap(String):Map<EndPoint, EndPoint>
> getNStorageEndPoints(String[]):Map<String, EndPoint[]>
> some of these should be getWriteSEP. Some getHintedSEP. Some getReadSEP.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message