cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Greene (JIRA)" <>
Subject [jira] Updated: (CASSANDRA-271) Rename <table> to <keyspace>
Date Thu, 30 Jul 2009 05:16:14 GMT


Michael Greene updated CASSANDRA-271:

    Attachment: 271_stress.diff

Oops, forgot stress test.

> Rename <table> to <keyspace>
> ----------------------------
>                 Key: CASSANDRA-271
>                 URL:
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Core
>            Reporter: Jonathan Ellis
>            Assignee: Jonathan Ellis
>             Fix For: 0.4
>         Attachments: 271-3.patch, 271-v2.patch, 271-v4.patch, 271.patch, 271_stress.diff
> Using <table> in the configuration file to mean "the unit over which key/cf pairs
are unique" is not useful.  It confuses both people from a relational background (the vast
-- vast! -- majority of users) and people from a Bigtable/HBase/Hypertable background, because
Cassandra's data model, while closer to BT than MySQL, is still different enough to be confusing.
 Both of these mistaken assumptions of familiarity have caused me problems explaining Cassandra
to actual users.  We are the newcomers by 30 years in one case and 2 years in the other; insisting
on our own, different interpretation of a familiry term seems silly.
> It's possible that calling it KeySpace will not solve the problem, but I see this as
a situation where the status quo does us no good at all -- the only connotations <table>
has for people are WRONG -- and changing it has a chance of improving the situation.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message