cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Ellis (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CASSANDRA-202) Refactor different getRow calls in Table.java to more specific name and add more logging information
Date Mon, 01 Jun 2009 16:13:07 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-202?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12715138#action_12715138
] 

Jonathan Ellis commented on CASSANDRA-202:
------------------------------------------

> By the same token, we should make all thrift APIs getRow calls

We _should_ have get_column, get_key_range, and a bunch of get_slice overloads.  The reason
we do not is that thrift does not support overloads, not because it's actually better to have
get_slice_by_names, get_slice_from, etc.

> Refactor different getRow calls in Table.java to more specific name and add more logging
information
> ----------------------------------------------------------------------------------------------------
>
>                 Key: CASSANDRA-202
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-202
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Jun Rao
>            Assignee: Jun Rao
>         Attachments: issue202.patchv1, issue202.patchv2
>
>
> The Table class has five different getRow methods. We need to change them to more appropriate
names. Also, when an IOException occurs, it would be useful to log the parameters of the request.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message