cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jun Rao (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CASSANDRA-202) Refactor different getRow calls in Table.java to more specific name and add more logging information
Date Wed, 17 Jun 2009 22:16:07 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-202?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12720947#action_12720947
] 

Jun Rao commented on CASSANDRA-202:
-----------------------------------

This is fine. I realize that there is enough debug info in weakReadLocal and weakReadRemote
in StorageProxy that provides the relevant context when an exception happens.

I still think that it's better to rename the 5 versions of getRow in Table though.

> Refactor different getRow calls in Table.java to more specific name and add more logging
information
> ----------------------------------------------------------------------------------------------------
>
>                 Key: CASSANDRA-202
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-202
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Jun Rao
>            Assignee: Jun Rao
>         Attachments: 202.patch, issue202.patchv1, issue202.patchv2
>
>
> The Table class has five different getRow methods. We need to change them to more appropriate
names. Also, when an IOException occurs, it would be useful to log the parameters of the request.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message