cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Ellis (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CASSANDRA-88) clean up CassandraServer and StorageProxy
Date Fri, 17 Apr 2009 22:14:14 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-88?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12700348#action_12700348
] 

Jonathan Ellis commented on CASSANDRA-88:
-----------------------------------------

04
    refactor read path: first we make readColumnFamily accept a ReadCommand, and use that
to clean out duplicate code in CassandraServer.  Then we clean up the duplicate versions ofthe
read methods in StorageService by making them ReadCommand-based, too.  [not touching multiget
code for now.]

03
    rename ReadResponseMessage -> ReadResponse

02
    clean up ReadCommand; it's basically a struct so use public final fields

01
    CASSANDRA-88 rename get_cf -> readColumnFamily; ReadMessage -> ReadCommand
    [Message message = ReadMessage.readMessage(readMessage) is just plain confusing]


> clean up CassandraServer and StorageProxy
> -----------------------------------------
>
>                 Key: CASSANDRA-88
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-88
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Jonathan Ellis
>            Assignee: Jonathan Ellis
>             Fix For: 0.3
>
>         Attachments: 0001-CASSANDRA-88-rename-get_cf-readColumnFamily-ReadMe.txt, 0002-clean-up-ReadCommand-it-s-basically-a-struct-so-use-p.txt,
0003-rename-ReadResponseMessage-ReadResponse.txt, 0004-refactor-read-path-first-we-make-readColumnFamily-acc.txt
>
>
> there is a ton of duplicate code here that makes it difficult to improve the thrift interface

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message