cassandra-client-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Naryshkin <konstant...@a-bb.net>
Subject Cassandra 0.8 and Erlang
Date Fri, 17 Jun 2011 18:47:25 GMT
I am working on getting an erlang application to write to Cassandra 0.8.0 . I installed Thrift
and used it to generate erlang from cassandra.thrift (using thrift --gen erl cassandra.thrift
). I tried to copy the syntax from several examples that I found, unfortunately I found the
following issue: Gets (the method that I am trying out) requires me to pass in a columnPath.
The syntax that I see in every example that I have looked at is something like: 

Cp = #columnPath{column_family="ipdr_usage"}. 

Which gives me an error of: "* 1: record columnPath undefined" 

I tried to import and compile just about everything I could think of. Obviously I tried both

c(cassandra_types). 
and 
import(cassandra_types). 

I am very new at Erlang, so it may be something very stupid, but does any one have any suggestion
or any good examples of how to do it? 

Konstantin 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message