carbondata-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From littleJava <...@git.apache.org>
Subject [GitHub] incubator-carbondata issue #433: [WIP] fix testcase failure for -Pno-kettle ...
Date Wed, 14 Dec 2016 08:46:33 GMT
Github user littleJava commented on the issue:

    https://github.com/apache/incubator-carbondata/pull/433
  
    i have checked the code, and switched to branch: spark2
    scala: 2.10.4
    
    when i ran : 
    mvn -DskipTests -Pspark-2.0  compile
    
    i got the error:
    
    ```
    [INFO] -------------------------------------------------------------
    [ERROR] COMPILATION ERROR :
    [INFO] -------------------------------------------------------------
    [ERROR] /Users/nathan/workspace/carbondata/core/src/main/java/org/apache/carbondata/scan/complextypes/StructQueryType.java:[32,49]
找不到符号
      符号:   类 GenericInternalRowWithSchema
      位置: 程序包 org.apache.spark.sql.catalyst.expressions
    [ERROR] /Users/user/workspace/carbondata/core/src/main/java/org/apache/carbondata/scan/complextypes/StructQueryType.java:[182,16]
找不到符号
      符号:   类 GenericInternalRowWithSchema
      位置: 类 org.apache.carbondata.scan.complextypes.StructQueryType
    [INFO] 2 errors
    ```
    
    there is no  `org.apache.spark.sql.catalyst.expressions.GenericInternalRowWithSchema.GenericInternalRowWithSchema`
in spark2
    
    how can i fixed it  ?


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message