camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Ludington <>
Subject camel-jetty and jetty version 9.4.7.v20170914
Date Mon, 23 Oct 2017 21:21:08 GMT
Camel jetty producer routes are not starting after updating to Spring Boot
1.5.8, which includes jetty version 9.4.7.v20170914

To test:
in master's camel-jetty pom.xml, set this line:


and the context fails to initialize with

org.apache.camel.RuntimeCamelException: java.lang.IllegalStateException:
Locker is not reentrant
Caused by: java.lang.IllegalStateException: Locker is not reentrant

For other reasons, we have to use jetty 9.4.x in our application; version
9.4.6.v20170531, the version included in spring-boot 1.5.7 does work and
functional normally.  Setting that jetty.version property in to that
version does work.

A commit last week,
, updates to spring-boot 1.5.8 and jetty-version 9.4.7.v20170914, but I did
not see that upon pulling from github.  Is this something that is already
addressed in master, or should a ticket be filed?

Thank you,

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message