camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Cosentino <ancosen1...@yahoo.com.INVALID>
Subject Re: Mysql-connector 8.0.8 not in maven, dependency error
Date Thu, 12 Oct 2017 12:26:06 GMT
Did you try with a different Karaf version?

--
Andrea Cosentino 
----------------------------------
Apache Camel PMC Member
Apache Karaf Committer
Apache Servicemix PMC Member
Email: ancosen1985@yahoo.com
Twitter: @oscerd2
Github: oscerd




 
 
 On Thursday, October 12, 2017, 2:19:06 PM GMT+2, Farkas Lajos <farkas.lajos@globustravel.com>
wrote: 





Hello,

it seems that camel-ftp is trying to install 
org.ops4j.pax.logging.pax-logging-api, which needs mysql-connect-8.0.8

Regards,
Lajos Farkas

On 10/12/17 10:16 AM, Claus Ibsen wrote:
> Hi
>
> The camel-ftp does not use mysql at all, so it must be something else
> that you are doing that causes this.
>
> On Wed, Oct 11, 2017 at 7:44 PM, Farkas Lajos
> <farkas.lajos@globustravel.com> wrote:
>> Hello Camel users,
>>
>>
>> i'm trying to install camel-ftp on karaf 4.0.4, and i'm getting this error:
>>
>>
>> 2017-10-11 19:24:45,106 | WARN  | ool-379-thread-7 | AetherBasedResolver
>> | 5 - org.ops4j.pax.logging.pax-logging-api - 1.8.5 | Error resolving
>> artifactmysql:mysql-connector-java:jar:8.0.8:Could not find artifact
>> mysql:mysql-connector-java:jar:8.0.8 in central
>> (http://repo1.maven.org/maven2/)
>> shaded.org.eclipse.aether.resolution.ArtifactResolutionException: Could not
>> find artifact mysql:mysql-connector-java:jar:8.0.8 in central
>> (http://repo1.maven.org/maven2/)
>>
>>
>> in the maven repository, there is no 8.0.8 version for mysql connector, but
>> for version 8.0.8-dmr.
>>
>> Is there a way to install camel-ftp, without this dependency?
>>
>> Thank you.
>>
>>
>>
>
>



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message