camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Stark <starki...@gmail.com>
Subject Error Building Camel
Date Wed, 16 Aug 2017 13:26:44 GMT
Hi

I try to get and build the latest camel-source

http://camel.apache.org/building.html


However when executing

mvn clean install -Pfastinstall

it fails with

[ERROR] Failed to execute goal
org.apache.felix:maven-bundle-plugin:3.3.0:manifest (bundle-manifest) on
project camel-test-cdi: Internal error in maven-bundle-plugin: Calc
manifest failed, state=
[ERROR] {ahc-version=2.0.34, env.XDG_SESSION_ID=1, os.name=Linux,
leveldbjni-version=1.8, camel.osgi.require.capability=,
project.issueManagement=org.apache.maven.model.IssueManagement@275fa2c9,
env.XFILESEARCHPATH=/usr/dt/app-defaults/%L/Dt,
os.detected.classifier=linux-x86_64, elsql-version=1.2,
rabbitmq-amqp-client-version=4.2.0,
maven-jboss-as-maven-plugin-version=7.7.Final, pom.modelVersion=4.0.0,
servlet-api-3.0-version=1.0, karaf4-version=4.1.1, xml-apis-version=1.4.01,
project.build.contributors=[], olingo-odata2-core-bundle-version=2.0.9_1,
avro-ipc-bundle-version=1.8.2_1, sun.os.patch.level=unknown,
rxjava2-version=2.1.2, project.version=2.20.0-SNAPSHOT,
cxf-xjc-utils-version=3.0.5, jedis-client-bundle-version=2.9.0_1,
box-java-sdk-version=2.1.1, camel.osgi.import.additional=,
spring-osgi-version=1.2.1, hamcrest-version=2.0.0.0, jnats-version=1.0,
env.IMSETTINGS_MODULE=none, json4s-bundle-version=3.2.8_1,
spring-security-version=4.2.3.RELEASE, splunk-version=1.6.3.0_1,
freemarker-bundle-version=2.3.23_1, chronicle-network-version=1.9.1,
jolt-bundle-version=0.1.0_1, organization.logo=
https://www.apache.org/images/asf_logo_wide.gif, olingo2-version=2.0.9,
geronimo-atinject-1.0-



My maven version is:
 mvn -version
Apache Maven 3.5.0 (ff8f5e7444045639af65f6095c62210b5713f426;
2017-04-03T21:39:06+02:00)
Maven home: /opt/maven
Java version: 1.8.0_131, vendor: Oracle Corporation
Java home: /usr/lib/jvm/java-1.8.0-oracle-1.8.0.131-1jpp.1.el7_3.x86_64/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "3.10.0-514.26.2.el7.x86_64", arch: "amd64",
family: "unix"
[cstark@cstark camel]$ http://camel.apache.org/building.html^C
[cstark@cstark camel]$


If you can help please let me know thanks
Christian

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message