camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Taariq Levack <taar...@gmail.com>
Subject Re: Camel Route Not Starting in Docker
Date Sun, 27 Aug 2017 06:22:39 GMT
Looks like you're connecting to a broker on localhost, which in docker is
not the same.

On 23 Aug 2017 03:47, "Jeremy Deane" <jeremydeane@hotmail.com> wrote:

> If start a local Spring-Boot App with a Camel Route listening to ActiveMQ,
> itself either local or from a Docker Container, then the Camel Route
> starts.
> That in turns creates a connection to ActiveMQ and the queue that the Route
> is polling.
>
> However, if I start that same Spring-Boot App (w/ Camel Route) in Docker,
> then the Spring-Boot App Starts but not the Camel Route; nor does it
> establish a connection. The weird part is that the ActiveMQ Camel Component
> says it established a connection:
>
> /Successfully connected to tcp://event-broker:61616/
>
> But when viewing the ActiveMQ Management Console there is no connection or
> queue. And I see this output from the App logs regarding the Route:
>
> /Total 0 routes, of which 0 are started. /
>
> I posted a similar question, from a different perspective, with the Docker
> details on StackOverflow:
>
> https://stackoverflow.com/questions/45774973/docker-
> user-defined-network-inter-container-communication-via-container-host-n
>
> The Spring-Boot App code is here:
>
> https://github.com/jtdeane/event-driven-microservices/
> tree/master/event-ingestion
>
>
>
> --
> View this message in context: http://camel.465427.n5.nabble.
> com/Camel-Route-Not-Starting-in-Docker-tp5811844.html
> Sent from the Camel - Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message