camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zoran Regvart <>
Subject Re: Spring Boot > 1.5 fails when camel-swagger-java in place
Date Wed, 19 Apr 2017 13:33:52 GMT
Hi Thomas

On Wed, Apr 19, 2017 at 3:08 PM, Thomas Weinschenk
<> wrote:
> where do I have to put the validation mode setting, property of the pom,
> application.yml or as an environment variable? I tried all three but I still
> get the same error.

in Spring Boot that setting needs to be prefixed with
``[1], so try setting
`` to `none`

> The log ouptut related to the failure is:
> Exception encountered during context initialization - cancelling refresh
> [snip]

I'm sure you have a exception preceding that one, that shows the
actual cause of the failure to initialize
`org.hibernate.validator.internal.engine.ConfigurationImpl`, you see
`NoClassDefFoundError`s occur after the fact when the class can't be
loaded, usually due to `ClassNotFoundException`,


Zoran Regvart

View raw message