camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From simpleuser <ceyhanka...@gmail.com>
Subject Apache Camel - ftp component - need to use absolute path
Date Wed, 29 Mar 2017 12:11:10 GMT
Hi,

I am trying to upgrade a product that uses an older camel version (2.15.1) .

I am trying to upgrade the camel version to 2.17.5

In the code base, camel ftp component is used with absolute paths...

After upgrade we saw that, files could not be consumed due to the following
error:

SftpComponent doesn't support absolute paths, "xxx" will be converted to
"yyy". After Camel 2.16, absolute paths will be invalid.

I can see that absolute paths are not supported starting with 2.16:

http://camel.apache.org/ftp.html <http://camel.apache.org/ftp.html>  

For our case, it will be very costly to change the existing code base.

My question : Is there any possibility to force camel ftp 2.17.5 to support
absolute paths as before in 2.15.1 (via config or other setting)?



--
View this message in context: http://camel.465427.n5.nabble.com/Apache-Camel-ftp-component-need-to-use-absolute-path-tp5796693.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message