camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From blackard <>
Subject Error encrypting value using camel-jasypt-2.18.1.jar
Date Thu, 16 Feb 2017 21:53:39 GMT

I tried searching and didn't see anything on this.  I tried encrypting a
value using the camel-jasypt-2.18.2.jar (Camel 2.18.2) following  I also found this same behavior with
the 2.18.1 release.  The issue _does not_ affect the 2.17.5 release.

C:\Programs\apache-camel-2.18.2\lib>java -jar camel-jasypt-2.18.2.jar -c
encrypt -i "the string to encrypt" -p password
Exception in thread "main" java.lang.NoClassDefFoundError:
        at org.apache.camel.component.jasypt.Main.<init>(
        at org.apache.camel.component.jasypt.Main.main(
Caused by: java.lang.ClassNotFoundException:
        at java.lang.ClassLoader.loadClass(
        at sun.misc.Launcher$AppClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        ... 2 more

This clearly differs from behavior with earlier versions, or with the
expected behavior according to the documentation:

Tooling dependencies for Camel 2.7 or better
Jasypt 1.7 onwards is now fully standalone so no additional JARs is needed.

View this message in context:
Sent from the Camel - Users mailing list archive at

View raw message