camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From janssen <janssen...@gmail.com>
Subject Re: Durable subscriber on an Oracle Advanced Queue (Topic)
Date Thu, 01 Dec 2016 14:18:16 GMT
Found the solution to our problem.

The problem was caused by a difference in character sets. The database uses
WE8ISO8859P15 which is not directly supported. The difference can cause
issues when setting the subscriber or reading / writing jmsproperties. 
The issue was solved by adding the ojdbc and the orai18n as embedded
dependency of our bundle.

Make sure you add the optional part as well otherwise osgi will not resolve
the bundle. 
 <Embed-Dependency>orai18n, ojdbc5, aqapi</Embed-Dependency>
 <Import-Package>*;resolution:=optional</Import-Package>




--
View this message in context: http://camel.465427.n5.nabble.com/Durable-subscriber-on-an-Oracle-Advanced-Queue-Topic-tp5790149p5790884.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message