camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonin Stefanutti <anto...@stefanutti.fr>
Subject Re: CDI before Camel 2.17?
Date Mon, 08 Aug 2016 09:21:42 GMT
Hi Brad,

The examples (camel-example-cdi.*) that are available in https://github.com/apache/camel/tree/master/examples
should work to some great extent in Camel versions prior to 2.17.0.

As these examples concentrate on the non-advanced features and the new version of Camel CDI
introduced in 2.17.0 managed to be largely backward compatible, these should work in prior
versions with some little adaptation.

You can find some more details about these non backward compatible changes in https://issues.apache.org/jira/browse/CAMEL-9201
and http://camel.apache.org/camel-2170-release.html.

For testing, Camel CDI test won't be available, though you can use plain Arquillian testing
support. You can find more info in http://camel.apache.org/cdi-testing.html.

If that’s not enough for you to wait until Camel 2.17 / Fuse 6.3, let me know and we’ll
try to help you further.

Antonin

> On 06 Aug 2016, at 00:30, Brad Johnson <brad.johnson@mediadriver.com> wrote:
> 
> Are there any good examples of how to use CDI with Camel before 2.17?
> Obviously that's a better option to go with and when the Fuse 6.3 release
> hits it's first milestone that's what I'll go to but until then I can use
> Camel 2.17 CDI test but have to use the older features with Fuse 6.2.1.
> 
> Unless there's a patch or upgrade that does this already?
> 
> Brad

Mime
View raw message