camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Thiessen <alexander.thies...@outlook.com>
Subject Dependency chain conflicts for karaf feature camel-cxf 2.17.1
Date Tue, 05 Jul 2016 09:29:06 GMT
Hi All,

I update my camel karaf feature from 2.16.3 to 2.17.1, and now I get the
following exception:

/org.apache.karaf.shell.support.MultiException: Error executing command on
bundles:
	Error starting bundle 225: Uses constraint violation. Unable to resolve
resource org.apache.camel.camel-cxf [org.apache.camel.camel-cxf [225](R
225.0)] because it is exposed to package 'org.springframework.beans' from
resources org.apache.servicemix.bundles.spring-beans
[org.apache.servicemix.bundles.spring-beans [119](R 119.0)] and
org.apache.servicemix.bundles.spring-beans
[org.apache.servicemix.bundles.spring-beans [118](R 118.0)] via two
dependency chains.

Chain 1:
  org.apache.camel.camel-cxf [org.apache.camel.camel-cxf [225](R 225.0)]
    import:
(&(osgi.wiring.package=org.springframework.beans)(version>=4.1.0)(!(version>=5.0.0)))
     |
    export: osgi.wiring.package: org.springframework.beans
  org.apache.servicemix.bundles.spring-beans
[org.apache.servicemix.bundles.spring-beans [119](R 119.0)]

Chain 2:
  org.apache.camel.camel-cxf [org.apache.camel.camel-cxf [225](R 225.0)]
    import:
(&(osgi.wiring.package=org.apache.camel.spring)(version>=2.17.0)(!(version>=2.18.0)))
     |
    export: osgi.wiring.package=org.apache.camel.spring;
uses:=org.springframework.beans
  org.apache.camel.camel-spring [org.apache.camel.camel-spring [54](R 54.0)]
    import:
(&(osgi.wiring.package=org.springframework.beans)(version>=3.2.0)(!(version>=4.0.0)))
     |
    export: osgi.wiring.package: org.springframework.beans/

I think the apache-camel-2.17.1-features.xml is not up-to-date. The
camel-spring feature use the spring feature [3.2,4) and the camel-cxf
feature has a dependency to camel-spring. But the camel-cxf bundle import
spring version [4.1,5). Is this an issues from camel side or I misunderstand
this exception? What I can do to resolve this problem?    

Thanks in advance 

Best Regards
Alexander




--
View this message in context: http://camel.465427.n5.nabble.com/Dependency-chain-conflicts-for-karaf-feature-camel-cxf-2-17-1-tp5784786.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message