camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From alexey-s <alex...@mail.ru>
Subject Re: Error in Karaf: Unknown protocol: mvn
Date Wed, 25 May 2016 07:17:14 GMT
In the file camel-core-2.17.1.jar, internal file META-INF/MANIFEST.MF have
row
Ignore-Package: com.googlecode.concurrentlinkedhashmap

but this package use in class org.apache.camel.util.LRUCache.

It's errror for OSGi.

Add this package to parameter Import-Package, or change usage classes 
ConcurrentLinkedHashMap and EvictionListener from package
"com.googlecode.concurrentlinkedhashmap" to
"org.apache.camel.com.googlecode.concurrentlinkedhashmap".


Regards, Alexey



--
View this message in context: http://camel.465427.n5.nabble.com/Error-in-Karaf-Unknown-protocol-mvn-tp5783042p5783060.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message