camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From henrik <hen...@synth.no>
Subject Re: camel-servlet is no-longer working in 2.16.1 (works in 2.15.3 and 2.16.0)
Date Thu, 07 Jan 2016 09:50:12 GMT
yihtserns wrote:
> Why are you trying to access
> *http://localhost:9090/appcontext/triggerimport/* when your Servlet URI is
> *servlet://jarchive*?
> 
> Shouldn't you be accessing
> *http://localhost:9090/appcontext/triggerimport/jarchive* instead?

Found the problem.  My config was slightly different from Mel's.  

My servlet-mapping url-patter was <url-pattern>/pp/import/*</url-pattern>
and I initialized the servlet as servlet://import/... 

I could access this with http://localhost:9090/appcontext/pp/import/start
earlier, but with 2.16.1 I had to use
http://localhost:9090/appcontext/pp/import/import/start

The fix was to use <url-pattern>/pp/*</url-pattern> instead.

Henrik




--
View this message in context: http://camel.465427.n5.nabble.com/camel-servlet-is-no-longer-working-in-2-16-1-works-in-2-15-3-and-2-16-0-tp5774558p5775952.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message