camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <>
Subject Re: Camel 2.16.1, regression with Spring Proxy
Date Tue, 08 Dec 2015 07:15:40 GMT

Minor migration can be expected when doing Camel upgrades between
minor versions. We list what you need to be aware of in the release

However a patch release shouldn't have any migration effort. Unless
due to security reasons causing that.

On Mon, Dec 7, 2015 at 6:56 PM, Jérémie <> wrote:
> thanks for your answer, even if i am a bit disappointed by it. Breaking
> existing application isn't good, and the actual behavior seem counter
> intuitive : if i forget only one annotation on an interface, i don't have
> any warning, but the proxy become invalid.
> Moreover, the "binding" attribute didn't work in Karaf with activemq :
> activemq-osgi 5.12.1 ship with an old namespace without this attribute, and
> i don't want to introduce dependencies on camel in my interface.
> --
> View this message in context:
> Sent from the Camel - Users mailing list archive at

Claus Ibsen
----------------- @davsclaus
Camel in Action 2:

View raw message