camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Cosentino <ancosen1...@yahoo.com.INVALID>
Subject Re: The new camel-swagger-java module in Apache Camel 2.16
Date Fri, 25 Sep 2015 12:56:39 GMT
I've upgraded Jackson to 2.6.2 while Claus was working on Camel-swagger-java.. I wasn't aware
of this problem, but we can downgrade Jackson for the moment and bring it back to version
2.6.1.
--Andrea Cosentino  ---------------------------------Apache Camel Committer  Email: ancosen1985@yahoo.com
 Twitter: @oscerd2  Github: oscerd  


     On Friday, September 25, 2015 2:49 PM, Aki Yoshida <elakito@gmail.com> wrote:
   

 Hi Claus,
The OSGi sample was included in CXF 3.1.3 and it uses this installer
description at the moment.
https://github.com/apache/cxf/blob/master/distribution/src/main/release/samples/jax_rs/description_swagger2_osgi/src/test/resources/features/features.xml

The same sample is also in 3.0.7-SNAPSHOT.

We haven't updated the cxf's features file with this swagger support
option yet because we are waiting for the 1.5.4 release.

What I noticed was that swagger build itself has some issue with
jackson 2.6.2. I wanted to look into it but haven't done it, so I
don't know if this is an issue with the test code or the code itself.
And this was the reason why I was bringing up this version question.

Thanks.
regards, aki



2015-09-25 14:26 GMT+02:00 Claus Ibsen <claus.ibsen@gmail.com>:
> What version of CXF is that?
>
>
> On Fri, Sep 25, 2015 at 1:05 PM, Aki Yoshida <elakito@gmail.com> wrote:
>> Hi Claus,
>> Cool.
>>
>> I wanted to try it out on the Karaf setup that we have for CXF with
>> swagger 1.5.4.
>>
>> Then I noticed that camel-swagger-java is asking for jackson [2.6,3).
>> I am wondering if we could make it down to [2.4,3).
>>
>> swagger itself is currently using 2.4.x and in the CXF's current Karaf
>> setup, we are bringing 2.4.6 in at the moment.
>> So, setting the range down to 2.4 makes life easier.
>> Or do you think we all should be going for 2.6.x?
>>
>> regards, aki
>>
>> 2015-09-23 15:11 GMT+02:00 Claus Ibsen <claus.ibsen@gmail.com>:
>>> Hi
>>>
>>> I just recorded a 5 minute video showing this in action
>>> http://www.davsclaus.com/2015/09/apache-camel-216-swagger-java-and-api.html
>>>
>>> At least with this new model the swagger is more light-weight (just
>>> java) and its auto detected easily from Camel, and you can run it in
>>> any JVM (not only servlet).
>>>
>>> I haven't yet tried on karaf, but it ought to work much better than
>>> the scala based.
>>>
>>> --
>>> Claus Ibsen
>>> -----------------
>>> http://davsclaus.com @davsclaus
>>> Camel in Action 2nd edition: https://www.manning.com/books/ibsen2
>
>
>
> --
> Claus Ibsen
> -----------------
> http://davsclaus.com @davsclaus
> Camel in Action 2nd edition:
> https://www.manning.com/books/camel-in-action-second-edition


  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message