camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From michaelesmann <camel.michael.esm...@gmail.com>
Subject Problem upgrading to Camel 2.15.3 in Karaf 3.0.4
Date Tue, 01 Sep 2015 09:02:55 GMT
Hi, 

I am trying to upgrade to Camel 2.15.3 from 2.14.1. We are using Karaf 3.0.4
as server. 

There is a problem with this, which can be reproduced this way: 

- Make a clean Karaf 3.0.4 installation 

- Start Karaf and install features: 

   feature:repo-add camel 2.15.3 
   feature:install camel 
   feature:install camel-script 

Now there is a warning and stacktrace in the Karaf logfile, as seen below.
It looks as if "something" is trying read a line comment as a Java class(?) 

Can anybody help?

Thanks, 
Michael 

---------------------------------------------------------------------------------------------------------

2015-09-01 10:53:56,794 | WARN  | l for user karaf | Activator                       
| 94 - org.apache.camel.camel-script - 2.15.3 | Cannot create the
ScriptEngineFactory: java.lang.ClassNotFoundException
java.lang.ClassNotFoundException: # Licensed to the Apache Software
Foundation (ASF) under one or more not found by groovy-all [92]
	at
org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1532)
	at
org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:75)
	at
org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1955)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)[:1.7.0_51]
	at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1844)
	at org.apache.felix.framework.BundleImpl.loadClass(BundleImpl.java:937)
	at
org.apache.camel.script.osgi.Activator$BundleScriptEngineResolver.getFactory(Activator.java:229)
	at
org.apache.camel.script.osgi.Activator$BundleScriptEngineResolver.getScriptNames(Activator.java:210)
	at
org.apache.camel.script.osgi.Activator$BundleScriptEngineResolver.access$000(Activator.java:191)
	at
org.apache.camel.script.osgi.Activator.getAvailableScriptNames(Activator.java:118)
	at
org.apache.camel.script.osgi.Activator.updateAvailableScriptLanguages(Activator.java:138)
	at
org.apache.camel.script.osgi.Activator.serviceChanged(Activator.java:184)
	at
org.apache.felix.framework.util.EventDispatcher.invokeServiceListenerCallback(EventDispatcher.java:932)
	at
org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:793)
	at
org.apache.felix.framework.util.EventDispatcher.fireServiceEvent(EventDispatcher.java:543)
	at org.apache.felix.framework.Felix.fireServiceEvent(Felix.java:4419)
	at org.apache.felix.framework.Felix.registerService(Felix.java:3423)
	at
org.apache.felix.framework.BundleContextImpl.registerService(BundleContextImpl.java:346)
	at
org.apache.felix.framework.BundleContextImpl.registerService(BundleContextImpl.java:320)
	at
org.apache.camel.impl.osgi.Activator$BaseService.doRegister(Activator.java:515)
	at
org.apache.camel.impl.osgi.Activator$BaseService.doRegister(Activator.java:507)
	at
org.apache.camel.impl.osgi.Activator$BundleMetaLanguageResolver.register(Activator.java:282)
	at org.apache.camel.impl.osgi.Activator.addingBundle(Activator.java:129)
	at
org.apache.camel.impl.osgi.tracker.BundleTracker$Tracked.customizerAdding(BundleTracker.java:431)
	at
org.apache.camel.impl.osgi.tracker.AbstractTracked.trackAdding(AbstractTracked.java:261)
	at
org.apache.camel.impl.osgi.tracker.AbstractTracked.track(AbstractTracked.java:234)
	at
org.apache.camel.impl.osgi.tracker.BundleTracker$Tracked.bundleChanged(BundleTracker.java:407)
	at
org.apache.felix.framework.util.EventDispatcher.invokeBundleListenerCallback(EventDispatcher.java:868)
	at
org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:789)
	at
org.apache.felix.framework.util.EventDispatcher.fireBundleEvent(EventDispatcher.java:514)
	at org.apache.felix.framework.Felix.fireBundleEvent(Felix.java:4403)
	at org.apache.felix.framework.Felix.startBundle(Felix.java:2092)
	at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955)
	at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:942)
	at
org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:518)
	at
org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:476)
	at
org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:417)
	at
org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:392)
	at Proxybf42107a_a14c_49e7_9b8a_d66cd0b730cd.installFeature(Unknown Source)
	at
org.apache.karaf.features.command.InstallFeatureCommand.doExecute(InstallFeatureCommand.java:72)
	at
org.apache.karaf.features.command.FeaturesCommandSupport.doExecute(FeaturesCommandSupport.java:38)
	at
org.apache.karaf.shell.console.AbstractAction.execute(AbstractAction.java:33)[25:org.apache.karaf.shell.console:3.0.4]
	at
org.apache.karaf.shell.console.OsgiCommandSupport.execute(OsgiCommandSupport.java:39)[25:org.apache.karaf.shell.console:3.0.4]
	at
org.apache.karaf.shell.commands.basic.AbstractCommand.execute(AbstractCommand.java:33)[25:org.apache.karaf.shell.console:3.0.4]
	at Proxy6a4b03e2_6a27_4df6_b0ae_344825a3da49.execute(Unknown Source)[:]
	at Proxy6a4b03e2_6a27_4df6_b0ae_344825a3da49.execute(Unknown Source)[:]
	at
org.apache.felix.gogo.runtime.CommandProxy.execute(CommandProxy.java:78)[25:org.apache.karaf.shell.console:3.0.4]
	at
org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:480)[25:org.apache.karaf.shell.console:3.0.4]
	at
org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:406)[25:org.apache.karaf.shell.console:3.0.4]
	at
org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)[25:org.apache.karaf.shell.console:3.0.4]
	at
org.apache.felix.gogo.runtime.Closure.execute(Closure.java:182)[25:org.apache.karaf.shell.console:3.0.4]
	at
org.apache.felix.gogo.runtime.Closure.execute(Closure.java:119)[25:org.apache.karaf.shell.console:3.0.4]
	at
org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:94)
	at
org.apache.karaf.shell.console.impl.jline.ConsoleImpl.run(ConsoleImpl.java:208)
	at
org.apache.karaf.shell.console.impl.jline.LocalConsoleManager$2$1$1.run(LocalConsoleManager.java:109)
	at java.security.AccessController.doPrivileged(Native Method)[:1.7.0_51]
	at
org.apache.karaf.jaas.modules.JaasHelper.doAs(JaasHelper.java:57)[26:org.apache.karaf.jaas.modules:3.0.4]
	at
org.apache.karaf.shell.console.impl.jline.LocalConsoleManager$2$1.run(LocalConsoleManager.java:102)[25:org.apache.karaf.shell.console:3.0.4]
  



--
View this message in context: http://camel.465427.n5.nabble.com/Problem-upgrading-to-Camel-2-15-3-in-Karaf-3-0-4-tp5771113.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message