camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henryk Konsek <hekon...@gmail.com>
Subject Re: Need help in running camel in raspberry pi
Date Tue, 07 Jul 2015 21:02:27 GMT
Hi Parul,

The LWM2M branch of Kura is known to be currently broken as far as I know.
Can you try to deploy the regular Kura distribution?

Cheers!

pon., 6.07.2015 o 08:23 u┼╝ytkownik Parul Agrawal <parulagrawal14@gmail.com>
napisał:

>
> Hi,
>
> I am trying to run Camel as OSgi bundle in Kura with raspberry as the
> target device.
> Just to get hands on I followed below mentioned steps.
>
> 1) Downloaded Kura from *https://github.com/eclipse/kura
> <https://github.com/eclipse/kura>* with lwm2m branch since I wanted
> support for Lwm2m in Kura.
>
> 2) Deployed Kura in raspberry pi as steps mentioned in *https://wiki.eclipse.org/Kura/Getting_Started
> <https://wiki.eclipse.org/Kura/Getting_Started>*
>
> 3) After that followed steps @ *http://java.dzone.com/articles/apache-camel-iot-world-eclipse
> <http://java.dzone.com/articles/apache-camel-iot-world-eclipse>* to
> bundle camel in Kura.
>
> As mentioned I installed all the jar files in raspberry pi and finally
> started my- camel-bundle.jar
> But in osgi console if I run "ls" command camel bundle is shown as
> unsatisfied.
> *33      Unsatisfied
> org.eclipse.kura.example.camel_osgi
> org.eclipse.kura.example.camel_osgi(bid=75)*.
>
> I have attached the *error.txt* file with the output of command ls, ss
> and comp.
> Request you to help me in debugging this issue.
> Since I am new to Camel,Kura,Raspberry pi kindly guide me in making this
> up and providing pointers or any kind of help
> with respect to this.
>
> Thanks in advance.
>
> Thanks and Regards,
> Parul
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message