camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From paupachle <pav...@gmail.com>
Subject Re: STARTTLS does not work
Date Wed, 22 Jul 2015 07:56:51 GMT
I have added the debugMode option and the result is interesting.
The STARTTLS is correctly sent by JavaMail but then that's the end of the
SMTP conversation,
the message is not sent.

karaf@root> DEBUG: setDebug: JavaMail version 1.4.4
DEBUG: getProvider() returning
javax.mail.Provider[TRANSPORT,smtp,com.sun.mail.s
mtp.SMTPTransport,Sun Microsystems, Inc.,1.4.4]
DEBUG SMTP: useEhlo true, useAuth true
DEBUG SMTP: trying to connect to host "xxxx", port 587, isSSL false

220 2.0.0 ip-xxx-xx-xxx-xxx ESMTP ecelerity 4.1.0.46749 r(Core:4.1.0.4) Wed,
22 J
ul 2015 06:43:30 +0000
DEBUG SMTP: connected to host "xxxx.net", port: 587

EHLO xxxx
250-ip-xxxx says EHLO to xxxx:49661
250-AUTH=LOGIN
250-AUTH LOGIN
250-8BITMIME
250-STARTTLS
250-PIPELINING
250 ENHANCEDSTATUSCODES
DEBUG SMTP: Found extension "AUTH=LOGIN", arg ""
DEBUG SMTP: Found extension "AUTH", arg "LOGIN"
DEBUG SMTP: Found extension "8BITMIME", arg ""
DEBUG SMTP: Found extension "STARTTLS", arg ""
DEBUG SMTP: Found extension "PIPELINING", arg ""
DEBUG SMTP: Found extension "ENHANCEDSTATUSCODES", arg ""
STARTTLS
220 2.0.0 continue

Then it should send the message but does not.
In principle processing the exchange should do that.
And the order may not be right, in the log notice it says Sending
MimeMessage before connecting.
Thanks,

pau




--
View this message in context: http://camel.465427.n5.nabble.com/STARTTLS-does-not-work-tp5769696p5769727.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message