camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charlie Mordant <cmorda...@gmail.com>
Subject Re: Spring versions in camel features file for Karaf
Date Mon, 18 May 2015 11:31:49 GMT
Hi,

No, it's not a no go. Don't forget you're in an OSGI environment so
theorically, you can run some required Spring 3.X module and their
according 4.x counterparts together :).

regards,

2015-05-18 9:10 GMT+02:00 Svend-Ole Nielsen <svend-ole.nielsen@vehco.com>:

> So a Karaf 2.4, Camel 2.15 and Spring 4 is a no go I guess.
>
> What a bummer...
>
> /Svend
>
> -----Oprindelig meddelelse-----
> Fra: Charlie Mordant [mailto:cmordant1@gmail.com]
> Sendt: 14. maj 2015 12:47
> Til: users@camel.apache.org
> Emne: Re: Spring versions in camel features file for Karaf
>
> Hi,
>
> As what I saw, camel-spring manifests are also excluding spring 4.x. In
> addition spring-dm does not support spr 4.x...
>
> Regards,
>
> 2015-05-13 16:57 GMT+02:00 Svend-Ole Nielsen <svend-ole.nielsen@vehco.com
> >:
>
> > Hi
> >
> > I have installed a plain vanilla Karaf version 2.4 with Camel 2.15.
> > According to the release notes Camel 2.15 supports Spring version 4+
> > which also appears to be the version that Karaf is using. According to
> > the feature for example camel-spring the version 4 is excluded. See
> > the snippet below.
> >
> > <feature name="camel-spring" version="2.15.2" resolver="(obr)"
> > start-level="50">
> >            <bundle
> >
> dependency="true">mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1</bundle>
> >            <feature version="[3.2,4)">spring</feature>
> >            <feature version="[1.2,2)">spring-dm</feature>
> >            <feature version="[3.2,4)">spring-tx</feature>
> >            <feature version="2.15.2">camel-core</feature>
> >            <bundle>mvn:org.apache.camel/camel-spring/2.15.2</bundle>
> > </feature>
> >
> > According to the pom of camel-spring it is dependent on version 4+ of
> > Spring, so I'm a bit confused. So my question is if I am missing
> > something, a bug or something different .... ??
> >
> > Anyway - the Karaf is installing 2 versions of Spring and is unable to
> > deploy a xml-spring file due to namespace mismatch.
> >
> > Any help would be greatly appreciated....
> >
> > /Svend
> >
> >
>
>
> --
> Charlie Mordant
>
> Full OSGI/EE stack made with Karaf:
> https://github.com/OsgiliathEnterprise/net.osgiliath.parent
>



-- 
Charlie Mordant

Full OSGI/EE stack made with Karaf:
https://github.com/OsgiliathEnterprise/net.osgiliath.parent

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message