camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: camel-swagger in karaf? not yet....
Date Wed, 01 Apr 2015 14:42:40 GMT
Hi

See the known issue section at
http://camel.apache.org/camel-2150-release.html

On Wed, Apr 1, 2015 at 4:24 PM, Ed Welch <ed@edjusted.com> wrote:
> With the release of 2.15.1 fixing a bug that prevented 2.15 from working in an OSGi environment,
figured I'd give camel-swagger feature a try...
>
> 2015-04-01 09:52:38,672 | ERROR | qtp3964738-67    | FeaturesPlugin                 
 | 88 - org.apache.karaf.webconsole.features - 3.0.3 | Can't install feature camel-swagger/2.15.1
> java.lang.IllegalStateException: Can't install feature camel-swagger/2.15.1:
> Could not start bundle mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.swagger-core/1.3.12_1
in feature(s) camel-swagger-2.15.1: Unresolved constraint in bundle org.apache.servicemix.bundles.swagger-core
[111]: Unable to resolve 111.0: missing requirement [111.0] osgi.wiring.package; (&(osgi.wiring.package=scala.reflect.api)(version>=2.10.0)(!(version>=3.0.0)))
>
> Vanilla Karaf 3.0.3
>
> Am I missing something or should I file a bug?
>
> Thanks!
> Ed



-- 
Claus Ibsen
-----------------
Red Hat, Inc.
Email: cibsen@redhat.com
Twitter: davsclaus
Blog: http://davsclaus.com
Author of Camel in Action: http://www.manning.com/ibsen
hawtio: http://hawt.io/
fabric8: http://fabric8.io/

Mime
View raw message