camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sagarsoni89 <sagar.s...@wipro.com>
Subject Decrypt Soap Response
Date Fri, 17 Apr 2015 17:10:41 GMT
Dear all,

I am invoking a secured SOAP WebService (HTTPS) using Camel CXF deployed in
Fuse. In the client, we have configured TrustStore and Keystore as per the
standard config (Http-conduit). We're able to hit the server via Netscaler.
The server is generating the response and sending it back to Netscaler.

When the response is received from Netscaler, it is encrypted and should be
decrypted by Camel CXF. The decryption is not happening and on the client we
get a parsing error since the response is all encrypted.

Any clues of what could be the problem ?

this is my ws client config

<http:conduit name="*.http-conduit">
    <http:tlsClientParameters>
      <sec:keyManagers keyPassword="******">
          <sec:keyStore file=&quot;&lt;keystore>.jks" password="******"
type="JKS"/>
      </sec:keyManagers>
      <sec:trustManagers>
          <sec:keyStore file=&quot;&lt;keystore>.jks" password="******"
type="JKS"/>
      </sec:trustManagers>
      <sec:cipherSuitesFilter>
        <sec:include>.*</sec:include>
      </sec:cipherSuitesFilter>
    </http:tlsClientParameters>
   </http:conduit>



--
View this message in context: http://camel.465427.n5.nabble.com/Decrypt-Soap-Response-tp5765983.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message