camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lichtin <lich...@yahoo.com>
Subject Re: Karaf with Camel 2.15.1, CXF 3.0.4 - which Spring versions can be used?
Date Mon, 06 Apr 2015 08:04:04 GMT
But don't you restrict the Spring version and exclude version 4 with the
version range?

I'm looking at
https://repository.apache.org/content/repositories/releases/org/apache/camel/karaf/apache-camel/2.15.1/apache-camel-2.15.1-features.xml
and see

    <feature version="[3.2,4)">spring</feature> 

The way I read this, version 4 is not accepted.


Willem.Jiang wrote
> As we doesn’t specify the spring version inside of camel feature, you need
> to choice the spring version yourself inside of Karaf. If you load the
> spring feature 4.0, it should work out of box.
> 
> --  
> Willem Jiang
> 
> Red Hat, Inc.
> Web: http://www.redhat.com
> Blog: http://willemjiang.blogspot.com (English)
> http://jnn.iteye.com (Chinese)
> Twitter: willemjiang  
> Weibo: 姜宁willem
> 
> 
> 
> On April 3, 2015 at 11:26:55 PM, Martin Lichtin (

> lichtin@.com

> ) wrote:
>> Using Camel 2.15.1 and CXF 3.0.4 in a Karaf container, I'm wondering how
>> one can control the Spring version.
>> Camel feature "camel-spring" loads Spring with
>>  
>> spring
>>  
>> which will result in loading 3.2.11.RELEASE.
>>  
>> Is there a way to use Spring 4?
>>  
>> - Martin
>>  
>>  
>>





--
View this message in context: http://camel.465427.n5.nabble.com/Karaf-with-Camel-2-15-1-CXF-3-0-4-which-Spring-versions-can-be-used-tp5765283p5765357.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message