camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Taariq Levack <taar...@gmail.com>
Subject Re: Problem with REST DSL (2.14.0) and String bean
Date Wed, 12 Nov 2014 17:19:40 GMT
Hi
Looks like camel-Jackson and camel-jaxb have different jaxb-api versions, 2.2 and 2.2.7
Try excluding jaxb-api from one of them.

Taariq

> On 12 Nov 2014, at 10:52, Vaïsse-Lesteven Arthur <arthurvaisse@yahoo.fr> wrote:
> 
> Hi Claus,
> 
> Firstly, thank for your answer.
> 
> I currently use Maven to manage dependencies, and I do not specify different
> versions of Apache Camel nor in the POM nor in the dependency tree. As you
> suggested it, I double checked it again. But, because human beings are
> fallible, I link you the maven dependencies and the related dependencies
> tree in case there exist some not obvious ignored requirements such as
> activemq version must be 5.10.0 with camel 2.14.0.
> 
> I hope this help you to state whether or not the error is due to a version
> conflict. For now, I don't see any version conflict.
> 
> Here is the dependencies of my project (I provide links to avoid a very long
> post on the mailing list)
> pom.xml that specify dependencies : http://arthurvaisse.free.fr/work/pom.xml
> text file containing the dependency tree :
> http://arthurvaisse.free.fr/work/dependencies_tree.txt
> 
> 
> Vaisse-Lesteven Arthur
> 
> 
> 
> --
> View this message in context: http://camel.465427.n5.nabble.com/Problem-with-REST-DSL-2-14-0-and-String-bean-tp5758812p5758965.html
> Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message