camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ronny Aerts <ronny.ae...@intris.be>
Subject RE: camel xslt with saxon 8.7
Date Thu, 27 Nov 2014 14:02:09 GMT
Hallo Willem,

Camel 2.13.3 is indeed an option but eventually I still want to follow the latest camel versions.
So using an 'older' version is only a workaround for now.

I want to use the sql component with the simple language to and therefore I need 2.14.0.

--
Kind regards,
Ronny Aerts – Intris nv – Wapenstilstandlaan 47, 2600 Berchem, Belgium
R&D Integration Architect
Prince II certified – ITIL certified
Tel: +32-3-326.50.75
-----Original Message-----
From: Willem Jiang [mailto:willem.jiang@gmail.com]
Sent: donderdag 27 november 2014 14:50
To: users@camel.apache.org
Subject: Re: camel xslt with saxon 8.7

You may consider to use Camel 2.13.3 instead of Camel 2.14.0.

--
Willem Jiang

Red Hat, Inc.
Web: http://www.redhat.com
Blog: http://willemjiang.blogspot.com (English) http://jnn.iteye.com (Chinese)
Twitter: willemjiang
Weibo: 姜宁willem



On November 27, 2014 at 9:12:48 PM, Ronny Aerts (ronny.aerts@intris.be) wrote:
> Hallo camel community,
>
> I just upgraded from camel 2.13.2 to 2.14.0.
>
> Camel git commit 1b38aad342529e98b5f76e11029ec50b1768949f (CAMEL-7753:
> xslt component
> - Store warning/errors etc as exchange properties so end users can get hold of those.
> Now works with camel-saxon also.) of 27-aug-2014 introduced
> saxonReceiverClass and saxonWarnerClass and a check in doStart method for the existence
of "net.sf.saxon.event.Receiver"
> and "net.sf.saxon.serialize.MessageWarner" in ...\camel-core\src\main\java\org\apache\camel\builder\xml\XsltBuilder.java.
> I assume that these classes are available Saxon-HE jar 9.6.x but not
> in the Saxon 8.7 library and that's a problem for me.
>
> I get an error when starting camel: Error pre-loading Saxon classes.
> Make sure you have saxon on the classpath, and the classloader can
> load the following two classes: net.sf.saxon.event.Receiver, net.sf.saxon.serialize.MessageWarner.
> I can't use the Saxon-HE because I use a lot of java calls inside xslt
> (eg to set message
> headers) and java calls are not supported in Saxon-HE home edition.
> That the reason why I use the full Saxon which is version 8.7 for now.
>
> Is there a solution to this problem?
>
> --
> Kind regards,
> Ronny Aerts - Intris nv - Wapenstilstandlaan 47,
> 2600 Berchem, Belgium
> R&D Integration Architect
> Prince II certified - ITIL
> certified
> Tel: +32-3-326.50.75
>
> Intris nv
> Wapenstilstandlaan 47
> B-2600 Berchem Tel. +32 3 326 50 75
> Fax +32 3 326 42 23
> www.intris.be [http://www.intris.be/mail/AEO_Sticker_108pxRGB.jpg]
>
>
> DISCLAIMER
> This is an e-mail from Intris. The information contained in this
> communication is intended solely for use by the individual or entity to whom it is addressed.
> Use of this communication by others is prohibited. If the e-mail
> message was sent to you by mistake, please notify support@intris.be,
> destroy it without reading, using, copying or disclosing its contents to any other person.
> We accept no liability for damage related to data and/or documents
> which are communicated by electronic mail.
>

Intris nv
Wapenstilstandlaan 47
B-2600 Berchem  Tel.  +32 3 326 50 75
Fax  +32 3 326 42 23
www.intris.be<http://www.intris.be/>    [http://www.intris.be/mail/AEO_Sticker_108pxRGB.jpg]
<http://www.intris.be>

DISCLAIMER
This is an e-mail from Intris. The information contained in this communication is intended
solely for use by the individual or entity to whom it is addressed.
Use of this communication by others is prohibited. If the e-mail message was sent to you by
mistake, please notify support@intris.be<mailto:support@intris.be>, destroy it without
reading, using, copying or disclosing its contents to any other person.
We accept no liability for damage related to data and/or documents which are communicated
by electronic mail.
Mime
View raw message