camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "BURN, James" <James.B...@oup.com>
Subject Issue with camel restlet route: response from solr URI isn't passed back to route
Date Tue, 16 Sep 2014 13:58:05 GMT
Hi

We are migrating our Camel routes to run through ServiceMix 5.1.1 which uses Camel 2.13.2

We have noticed an issue with this version which doesn't appear in our older versions (ServiceMix
4.5.3: Camel 2.10.7)

Here's an example restlet route:

<?xml version="1.0" encoding="UTF-8"?>
<blueprint xmlns="http://www.osgi.org/xmlns/blueprint/v1.0.0"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:cm="http://aries.apache.org/blueprint/xmlns/blueprint-cm/v1.0.0"
    xsi:schemaLocation="http://www.osgi.org/xmlns/blueprint/v1.0.0            http://www.osgi.org/xmlns/blueprint/v1.0.0/blueprint.xsd
    http://camel.apache.org/schema/blueprint http://camel.apache.org/schema/blueprint/camel-blueprint.xsd">
    <camelContext xmlns="http://camel.apache.org/schema/blueprint" id="camel-serviceendpoint">
        <route>
            <from uri="restlet:http://localhost:8080/testURL?restletMethod=get"/>
            <setExchangePattern pattern="InOut"></setExchangePattern>
            <to uri="http://localhost:8983/solr/collection1/update?bridgeEndpoint=true&amp;commit=true"
pattern="InOut"/>
            <setBody>
                <simple> Restlet Test</simple>
            </setBody>
        </route>
    </camelContext>
</blueprint>

When I run this in our old environment SM 4.5.3/Camel 2.10.7 we get a response back (albeit
a junk one depending on what the solr server gives back)

However with our new environment (SM5.1.1/Camel 2.13.2) requests for localhost:8080/testURL
give no response.

This affects a large part of our system and is holding us from moving forwards with Camel.

I noted there was an issue a year ago: http://camel.465427.n5.nabble.com/Setting-Body-in-restlet-route-without-to-does-not-work-td5732285.html
though this seemed independent of a call <to uri=... so I'm not sure if is connected.

I've tried to track through the change log between the 2 versions of Camel we are looking
at but can't find anything what has been added which we need to include to make this work.

Any ideas well appreciated.

Thanks

James



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message