camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jwblackw <jamesblackw...@gmail.com>
Subject I need to install some python osgi library
Date Wed, 03 Sep 2014 17:39:08 GMT
Hi.  I am trying to get the scripting languages working in a camel route like
this:

For Groovy:
<choice>
  <when>
    <groovy>true</groovy>
    <to uri"file:/usr/local/jimmy/B"/>
  </when>
  <otherwise>
    <to uri"file:/usr/local/jimmy/C"/>
  </otherwise>
</choice>

For Python:
<choice>
  <when>
    <python>true</python>
    <to uri"file:/usr/local/jimmy/B"/>
  </when>
  <otherwise>
    <to uri"file:/usr/local/jimmy/C"/>
  </otherwise>
</choice>

I have camel-groovy imported into Karaf and the groovy example works.
There is no camel-python to import, so I can't get the python example
working.
Claus has suggested that I "need to install some python osgi library"
Does anyone know which one?

I have tried camel-script, but it does nothing.
It seems to be just interfaces, no actual implementations.

Can someone take 15 minutes and try to get a python example working in
camel.
I don't think it can be done.




--
View this message in context: http://camel.465427.n5.nabble.com/I-need-to-install-some-python-osgi-library-tp5756021.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message