camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: What version of CDI is supported?
Date Tue, 01 Jul 2014 16:03:16 GMT
Hi

Whatever Apache Deltaspike supports as that is what we use for camel-cdi.

On Tue, Jul 1, 2014 at 5:51 PM, Anton-2 <kurrent93@gmail.com> wrote:
> Hi
>
> I am trying to get Camel working with CDI, am am having some success,
> however, I have run into the following error:
>
> [ERROR] Caused by: java.lang.IncompatibleClassChangeError: Class
> org.apache.camel.cdi.internal.CamelContextBean does not implement the
> requested interface javax.enterprise.inject.spi.BeanAttributes
>
> So, I am wondering, what version of CDI is supported by Camel currently?
>
> Thanks
>
>
>
> --
> View this message in context: http://camel.465427.n5.nabble.com/What-version-of-CDI-is-supported-tp5753152.html
> Sent from the Camel - Users mailing list archive at Nabble.com.



-- 
Claus Ibsen
-----------------
Red Hat, Inc.
Email: cibsen@redhat.com
Twitter: davsclaus
Blog: http://davsclaus.com
Author of Camel in Action: http://www.manning.com/ibsen
hawtio: http://hawt.io/
fabric8: http://fabric8.io/

Mime
View raw message