camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rubancsp <>
Subject Re: Possible bug with multicast shareUnitOfWork
Date Mon, 07 Jul 2014 15:09:06 GMT
Corrected typo error

Hi Willem

We are getting the OOM memory error in our production environment due to the
lot of stuck threads.
while analyzed the code we found that one of the camel route which is using
the mulitcast is the reason for the stuck thread.This is intermittent issue

Please find the below code snippet which we used for multi casting.(making
the two parallel web service call)

Camel version:2.10.3

<camel:log message="inside multicast route"
                        <camel:multicast strategyRef="aggregatedData" 

                                <to uri="direct:WB" />
                                <to uri="direct:CEN" />


Please find the below two logs:

Logs which is causing the stuck thread:
30 Jun 2014 15:10:42,823 ********** [] [14.01] ERROR [Camel (camel-1) thread
#7 - Multicast] invokeCentury - inside century route

Log which is working fine:

30 Jun 2014 15:10:58,105 *************** [] [14.01] ERROR [Camel (camel-1)
thread #2 - Multicast] invokeCentury - inside century route
30 Jun 2014 15:10:58,105 ************** [14.01] ERROR [Camel (camel-1)
thread #5 - Multicast] invokeWBServices - inside wb route

Here is my questions: 1)we are using the default camel thread pool for the
making the two synchronous calls and not customizing the default thread we need to make any change in the above code to customize the thread
pool setting(like min pool size max.pool size etc).
2) what will happen to worked thread  if we did n't get any response from
the external system . Thread pool terminate the worked thread or we need to
handle it in our code.

It would be great if you provide some suggestion on the above issue.

Please let me know if you need any additional details.


View this message in context:
Sent from the Camel - Users mailing list archive at

View raw message