camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Müller <christian.muel...@gmail.com>
Subject Re: Camel-hbase : problem with qualifier "id"
Date Thu, 26 Jun 2014 22:18:44 GMT
I can confirm this issue. I have raised a JIRA [1] and work on a fix.

[1] https://issues.apache.org/jira/browse/CAMEL-7547

Best,
Christian
-----------------

Software Integration Specialist

Apache Member
V.P. Apache Camel | Apache Camel PMC Member | Apache Camel committer
Apache Incubator PMC Member

https://www.linkedin.com/pub/christian-mueller/11/551/642


On Wed, Jun 25, 2014 at 11:33 AM, A577127 <antoine.matyja@worldline.com>
wrote:

> Hello,
>
> I'm not sure if this is a bug or an "undocumented" feature so I put this
> here.
>
> When using camel-hbase's producer, if you want to use an HBase qualifier
> with the value "id", it doesn't work.
>
> For example : I have an HBase table "registrations" with a family "token"
> and a qualifier "id". To scan it, I use this route :
>
>
>
> However the result doesn't give the database values. I tryed with another
> qualifier and it worked fine.
>
> I found out that when the producer tries to resolve the input parameters,
> this instruction goes wrong :
>
>
>
> This should get a String with the value "id", but instead it gets the value
> of the breadcrumbID header which is "ID-L83577-52983-1403687981986-0-1".
>
> Thanks
>
>
>
> --
> View this message in context:
> http://camel.465427.n5.nabble.com/Camel-hbase-problem-with-qualifier-id-tp5752781.html
> Sent from the Camel - Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message