camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Sicker <boa...@gmail.com>
Subject Re: Getting Bad Request response invoking REST web service
Date Sun, 22 Jun 2014 17:02:19 GMT
I was going to suggest that perhaps you were sending too many headers that
was causing the server to blow up, but I guess it was the opposite! I've
actually had different problems before when the browser's Accept-Encoding
was sent to a web service invoked by CXF which didn't understand said
encoding itself. In summary, it's usually the headers!


On 22 June 2014 09:52, Claus Ibsen <claus.ibsen@gmail.com> wrote:

> Hi
>
> See the section _Calling using GET or POST_ at
> http://camel.apache.org/http
>
> On Sun, Jun 22, 2014 at 6:11 AM, madhu_online1 <Nair.Madhu@aoins.com>
> wrote:
> > I was missing this:-
> > .setHeader(Exchange.HTTP_METHOD, constant("GET"))
> >
> >
> >
> > works now..surprising it wouldn't use a GET by default.
> >
> >
> >
> >
> >
> >
> > --
> > View this message in context:
> http://camel.465427.n5.nabble.com/Getting-Bad-Request-response-invoking-REST-web-service-tp5752659p5752661.html
> > Sent from the Camel - Users mailing list archive at Nabble.com.
>
>
>
> --
> Claus Ibsen
> -----------------
> Red Hat, Inc.
> Email: cibsen@redhat.com
> Twitter: davsclaus
> Blog: http://davsclaus.com
> Author of Camel in Action: http://www.manning.com/ibsen
> hawtio: http://hawt.io/
> fabric8: http://fabric8.io/
>



-- 
Matt Sicker <boards@gmail.com>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message