camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GalinKinlin <galinkin...@hotmail.com>
Subject Re: IncompatibleClassChangeError
Date Tue, 17 Jun 2014 22:06:20 GMT
I had this error just this morning.

Basically, it means you are using an old version of a jar to build some part
of your functionality, and a new jar to run it. I was using Spring
3.1.1.RELEASE within my base service, but Camel was using Spring
3.2.8.RELEASE. This is most likely your issue. Check your dependency tree
for conflicting Spring versions.

If it is Spring, but it is not possible to upgrade your Spring (for whatever
reason), I know Camel 2.12.2 does not suffer from this particular error.



--
View this message in context: http://camel.465427.n5.nabble.com/IncompatibleClassChangeError-tp5752456p5752459.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message