camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <willem.ji...@gmail.com>
Subject Re: As of Today twitter requires SSL - is it a setting for Camel Twitter component?
Date Wed, 15 Jan 2014 03:06:41 GMT
Which version of Camel are you using?
I just checked the code, the default setting of usingSSL of Twitter4j 3.0.5 is true.
Current camel-twitter component doesn’t have API to set usingSSL, I just filled a JIRA[1]
to provide that option and enable the SSL by default.

[1]https://issues.apache.org/jira/browse/CAMEL-7134

--  
Willem Jiang

Red Hat, Inc.
Web: http://www.redhat.com
Blog: http://willemjiang.blogspot.com(http://willemjiang.blogspot.com/) (English)
http://jnn.iteye.com(http://jnn.javaeye.com/) (Chinese)
Twitter: willemjiang  
Weibo: 姜宁willem



On January 15, 2014 at 9:19:47 AM, heregear (eric@heregear.com) wrote:
>  
> Hi.
>  
> Is there a way to enable SSL for Camel Twitter component?
>  
> FYI: as of today Twitter is requiring SSL connections. The Camel  
> Twitter
> component no longer works, and I can't see a way to enable ssl.  
>  
> Twitter4j directly works, and I've validated this by scrapping  
> my use of
> using it directly both with and without ssl enabled...without  
> it enabled,
> connection is refused 403, every time...
>  
> Thanks.
>  
>  
>  
> --
> View this message in context: http://camel.465427.n5.nabble.com/As-of-Today-twitter-requires-SSL-is-it-a-setting-for-Camel-Twitter-component-tp5745967.html
 
> Sent from the Camel - Users mailing list archive at Nabble.com.  
>  


Mime
View raw message