camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joao Vicente <>
Subject Camel properties component not being resolved when configuring data source
Date Sat, 16 Nov 2013 13:45:48 GMT
I am having some trouble getting a data source setup using Camel properties
So, I have a that contains configuration for my datasource
(showing only url for brevity)
My route builder seems to be able to resolve the property, but the data
source does not seem to do so.
The evidence for this is shown in the console output below.
I wonder could anyone shed some light to why this could be happening?

	<bean id="properties"
		<property name="location" value=""/>

	<bean id="auditDataSourceStg"
		<property name="driverClassName" value="oracle.jdbc.driver.OracleDriver"/>
		<property name="url" value="{{datasource.stg.url}}"/>
		<property name="username" value="{{datasource.stg.username}}"/>
		<property name="password" value="{{datasource.stg.password}}"/>
		<property name="initialSize" value="5" />
		<property name="maxActive" value="10" />
	    public void configure() {
	        .log("[queryyBuilder] url:{{datasource.stg.url}}")

Console output
	2013-11-16 13:20:15,609 [queryBuilder] INFO  route1                        
- [queryBuilder] url:jdbc:oracle:thin:...
	Cannot create JDBC driver of class 'oracle.jdbc.driver.OracleDriver' for
connect URL '{{datasource.stg.url}}'

View this message in context:
Sent from the Camel - Users mailing list archive at

View raw message