camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From JavaAdam <a.weh...@cenit.de>
Subject Is the higher OSGi version really needed?
Date Mon, 09 Sep 2013 07:38:30 GMT
Hi,

I have tried to deploy an OSGi application based on Apache Camel 2.11.1 on a
IBM WebSphere Application Server 8. But I failed, because Camel 2.11.1
requires a newer OSGi Specification than the WAS provides (Equinox 3.6.1).
My investigation shows that the import version of org.osgi.util.tracker was
increased from 1.4 to 1.5 in 2.11.x. I wonder if this version jump is really
needed or if it just happend automatically because of some dependencies in
the build system?

Fact is, that Apache Camel cannot be used on WAS 8 within a "real" OSGi
application based on the provided OSGi platform. 

Indeed the solution could be to provide an own OSGi platform embedded in my
application. But this is not my favorite solution.

Thanks
Adam





--
View this message in context: http://camel.465427.n5.nabble.com/Is-the-higher-OSGi-version-really-needed-tp5738924.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message