camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: mvn build with -Pfastinstall not enabling noassembly flag?
Date Wed, 31 Jul 2013 06:13:51 GMT
On Wed, Jul 31, 2013 at 2:45 AM, Willem jiang <willem.jiang@gmail.com> wrote:
> It looks like setting the properties through the Profile doesn't work.
> To work around it we could disable the assembly step by default, but we need to enable
it by using -Passembly when doing deploy and release.
>
> Any thought?
>

-1

I want the assembly to run when I do my builds to ensure that it
works. And this has been the default every since the start of the
project.


> --
> Willem Jiang
>
> Red Hat, Inc.
> FuseSource is now part of Red Hat
> Web: http://www.fusesource.com | http://www.redhat.com
> Blog: http://willemjiang.blogspot.com (http://willemjiang.blogspot.com/) (English)
>           http://jnn.iteye.com (http://jnn.javaeye.com/) (Chinese)
> Twitter: willemjiang
> Weibo: 姜宁willem
>
>
>
>
> On Wednesday, July 31, 2013 at 5:39 AM, Christian Müller wrote:
>
>> It's the same for me. I think the intention was to skip the assembly step...
>> Feel free to "fix" it.
>>
>> Best,
>> Christian
>> -----------------
>>
>> Software Integration Specialist
>>
>> Apache Camel committer: https://camel.apache.org/team
>> V.P. Apache Camel: https://www.apache.org/foundation/
>> Apache Member: https://www.apache.org/foundation/members.html
>>
>> https://www.linkedin.com/pub/christian-mueller/11/551/642
>>
>>
>> On Fri, Jul 19, 2013 at 12:14 PM, Aki Yoshida <elakito@gmail.com (mailto:elakito@gmail.com)>
wrote:
>>
>> > I would like to avoid the lengthy assembly step in the build at the
>> > end when I quickly just build the camel project.
>> >
>> > By looking at camel's parent/pom.xml, it seems that it was intended to
>> > not assemble the distribution when built with the fastinstall profile.
>> > <profile>
>> > <id>fastinstall</id>
>> > <activation>
>> > <property>
>> > <name>fastinstall</name>
>> > </property>
>> > </activation>
>> > <properties>
>> > <maven.test.skip.exec>true</maven.test.skip.exec>
>> > <noassembly>true</noassembly>
>> > </properties>
>> >
>> > but I see the assembly phase is always executed when I built it with
>> > -Pfastinstall.
>> >
>> > I can only disable the assembly step by setting the noassembly flag
>> > explicitly like:
>> >
>> > mvn -Dnoassembly=true -Pfastinstall
>> >
>> > Not sure if anyone have this problem, it is intended that way or has
>> > something to do with my environment?
>> >
>> > thanks.
>> > aki
>>
>
>
>



-- 
Claus Ibsen
-----------------
Red Hat, Inc.
Email: cibsen@redhat.com
Twitter: davsclaus
Blog: http://davsclaus.com
Author of Camel in Action: http://www.manning.com/ibsen

Mime
View raw message