camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aki Yoshida <elak...@gmail.com>
Subject Re: mvn build with -Pfastinstall not enabling noassembly flag?
Date Wed, 31 Jul 2013 12:07:20 GMT
Hi,
thanks Raúl,.
setting assembly.skipAssembly in the fastinstall profile seems to work
(goes into apache-camel and does a little bit of processing but skips
the assembling itself), It's not as fast as using -Dnoassembly=true
explicitly which completely skips the step, though.

I have to rerun it to verify it. If it is verified to work, I'll add
this prop setting line in the fastinstall profile.

regards, aki


2013/7/31 Raul Kripalani <raul@evosent.com>:
> Have you tried the assembly.skipAssembly property instead?
>
> Regards,
> Raúl.
> On 19 Jul 2013 11:14, "Aki Yoshida" <elakito@gmail.com> wrote:
>
>> I would like to avoid the lengthy assembly step in the build at the
>> end when I quickly just build the camel project.
>>
>> By looking at camel's parent/pom.xml, it seems that it was intended to
>> not assemble the distribution when built with the fastinstall profile.
>>     <profile>
>>       <id>fastinstall</id>
>>       <activation>
>>         <property>
>>           <name>fastinstall</name>
>>         </property>
>>       </activation>
>>       <properties>
>>         <maven.test.skip.exec>true</maven.test.skip.exec>
>>         <noassembly>true</noassembly>
>>       </properties>
>>
>> but I see the assembly phase is always executed when I built it with
>> -Pfastinstall.
>>
>> I can only disable the assembly step by setting the noassembly flag
>> explicitly like:
>>
>> mvn -Dnoassembly=true -Pfastinstall
>>
>> Not sure if anyone have this problem, it is intended that way or has
>> something to do with my environment?
>>
>> thanks.
>> aki
>>

Mime
View raw message