camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Müller <christian.muel...@gmail.com>
Subject Re: MailComponent/MailConsumer misses Mails
Date Thu, 23 May 2013 14:25:46 GMT
Camel 2.6.0 is a bit old and not supported anymore. Do you have a chance to
try a newer version (e.g. 2.11.0) and check whether it behaves in the same
way!?

Best,
Christian

Sent from a mobile device
Am 23.05.2013 11:01 schrieb "cgiera" <christoph.giera@mic-cust.com>:

> Hello,
>
> I'm facing strange problems when consuming mails from a cyrus mail server.
> Some mails were not processed but appear as SEEN in the mailbox.
> I've added the mail debug option to the route and I was pretty confused
> when
> analyzing the log:
>
> First poll is quite normal: 14 new mails, 14 get fetched and processed.
>
>
>
>
> Second poll is very confusing to me:
> 14 new messages and only 11 get fetched.
> Missing emails are 266, 267 and 268, but they still exist in the
> mailbox(marked as SEEN).
>
> Our camel application was (and still is) the only client which was
> connected
> to this mailbox.
> So I've to assume that the camel MailComponent has marked as seen(but not
> processed the mail).
>
>
>
> We are using camel 2.6.0 and cyrus-imapd-2.3.16-6.el6_2.5.x86_64.
>
> The route looks like the following:
>
>
> This behaviour is almost everytime reproducable when loading "a lot" of
> messages to the mailbox(~25+).
> Mailserver log shows that our camel application is the only connected
> client.
>
> Any help/advice/hint would be nice, I don't have a clue what I can do or
> where I should start my next analyzes.
>
> kind regards,
> Christoph
>
>
>
>
>
> --
> View this message in context:
> http://camel.465427.n5.nabble.com/MailComponent-MailConsumer-misses-Mails-tp5733010.html
> Sent from the Camel - Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message